Can't subscribe


Hey guys,

I tried to subscribe to the newsletter earlier from the homepage on Chrome. When I clicked the button, the screen dimmed as if an overlay was going to appaer either didn’t, so just a dark screen. Had to press escape to get it to go away.

Can’t replicate it on my iPad now though - fixed?


I’m having trouble reproducing this bug. When I click “subscribe” from the footer, I correctly get the lightbox:


FWIW, It works for me. I’m on Windows 10 w/ Chrome.


Just solved this - weirdly, the lightbox is blocked by AdBlock.


Ah, yeah Adblock can do some weird things.

For the good of humanity and to support content creators and the free web, you should use Adblock extensions to maintain a blacklist rather than a whitelist. To default to blocking all ads for every site seems a bit harsh to me. If a site’s ads are intrusive to your experience on the site then block them.


I’d actually recommend looking at maybe Ublock Origins. Adblock Plus (I assume that’s what you’re using) will now be serving paid ads to you.

That aside @Vocino - although I see what you mean by blacklisting sites that are bad for intrusive ads and such, there are unfortunately many malicious ads that get injected into legitimate websites. History has proven this. I’d rather block ads by default to protect myself from potentially malicious ads, and whitelist my own specific sites as needed.


Yeah I’m the same on this. I don’t like advertising and prefer to choose which sites I allow it from or want to support. If they only gain revenue by people clicking on ads, and I never click on ads, then it makes no difference anyway. Most sites do it so badly (especially on mobile) that I’d rather protect my computer & bandwidth by blocking by default.


This isn’t necessarily true. We have gone off topic though. Happy to discuss this elsewhere if you’re interested.