Will someone help me figure out my headset and PC settings?


#1

I was gifted both a monitor and a headset for my birthday. I didn’t have speakers beforehand, but now I have speakers in my monitor. So, especially when watching videos, I have my sound going through my monitor. When I want to switch to my headset, I go to my playback devices and switch it to my default device and default communications device. this apparently is causing issues, because then half my programs will go through my monitor and half will go through my headset. I find I have to actually go to the programs and either restart them, or go into settings and change it to my headset. It’s pretty tedious really.

Any ideas on how to prevent this? It’s annoying x.x


#2

Unfortunately, this is just how Windows operates. The “default” output device doesn’t refresh on the fly like that where it would switch mid-stream in most apps.

Most displays that have speakers also have an audio jack. If that’s the case, you would solve that issue.


#3

Alright, new problem. I literally just configured the mic on my headset, and then 5 minutes later, it just stops working. I swear to god, I might just break it. On a side note, i can’t figure out if there is a way/how to send a text message on mumble to tell you my mic is shitting out on me :frowning:


#4

You can right click the channel (e.g. Lobby) and go to Send Message.


#5

Make sure your speakers and headphones are not running in exclusive-mode.

To change the exclusive-mode settings of a playback or recording device

  1. Right-click the speaker icon in the notification area, which is located on the right side of the taskbar, and select Playback Devices or Recording Devices.
  2. After the Sound window appears, select Playback or Recording. Next, select an entry in the list of device names, and click Properties.
  3. After the Properties window appears, click Advanced.
  4. Clear the check box to disable exclusive-mode use of the device,

#6

I think that fixed it. :smiley: Thanks!


#7

Yeah didn’t fix my mic :frowning: I swear. I don’t understand why it’s being so difficult.


#8

I assume it’s a USB headset/mic? Could something else be overriding it?


#9

It’s not USB. It’s the HyperX Cloud, uses the audio jacks.

So, it started working on mumble (although I wasn’t talking, it was working). I exited mumble to go talk on curse with a friend, and the minute I exited curse my mic went to unavailable on my sound panel thing (http://i.imgur.com/XjXWmOj.png). Don’t know why. Tried unplugging and plugging back in, disabling and enabling, just random stuff. None of it worked. So I restarted my computer. When it booted back up, It was back to showing as working and the green moving up and down when I talked. I got on curse, it immediately went to unavailable. Damn.

Restarted computer again, got on curse, and it worked this time around.

Any ideas?


#10

Are the audio settings within the applications set to look for a default device or a specified one?


#11

Have you checked if the monitor has a headphone jack on the back or side? Then you could plug the audio-out into the monitor and your mic-in into your PC. Hope your cables are long enough.


#12

Anytime you mess around with a lot of settings in Windows, it’s almost always very beneficial to restart. I don’t know why Windows bugs out when you mess around with settings too long, but a restart almost always fixes it.


#13

For audio, I think everything is set to default. For my mic, it is set specifically to my headset.


#14

There is one in the back, I’ll try that later today. It came with cable extension things, so it shouldn’t be a problem.